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1. What is SPSS 20 for Windows?

SPSS 20 is a software package for data analysis. Because SPSS is a Windows programme, you
can view and edit your data by pointing and clicking the movable windows, dropdown menus
and dialogue boxes. SPSS 20 can be used to enter, manipulate and analyse data. You can also

use SPSS 20 to produce graphics of your data.

2. Viewing data and output in SPSS

The dataset used in the following examples is the British Social Attitudes Survey, 2011. The

British Social Attitudes Survey asks over 3,000 people what it’s like to live in Britain and what
they think about how Britain is run. This dataset can be downloaded from the UK Data Service

website, after completing a short registration.

2.1 Data View and Variable View
Datasets in SPSS 20 are most commonly saved as .sav SPSS data files. Open SPSS 20 and use

File > Open to open your dataset. There are two ways to view the data: in the Data View or
the Variable View tabs. The tabs to switch between the two are at the bottom left of the

screen.

Data View | “ariable YWiew
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Click on the Data View tab (bottom left of screen). In Data View:
e Each column represents a variable in the survey. This is often a response to a question
or derived from answers to a question or several questions. Hovering your cursor over

the variable name at the top of a column will show the longer variable label

e Each row represents an individual respondent, this might be a person (as in the British
Social Attitudes Survey), or a household, or family unit, or other unit. These rows are

often referred to as cases (or observations)

e Itis common for datasets to have a unique identifier towards the beginning of the
dataset, often the first column. It is possible to reorder the data in SPSS, so a unique
identifier is required to identify particular cases, even if the data has been reordered.
In the 2011 British Social Attitudes Survey, the data is uniquely identified by “Serial

Number :Q1" (Serial), which is in the first column

File Edit VYiew Data Transform Anahze Graphs Ulilities Add-ons Window Help
T I . B i @A (> @ A8g
SHe I e~ B B &HEBEBLHE 4909 %
Visible: 854
Serial SPoint stratlD PopBand GOR2 WtFactor OldWi ABCVer Country XYVer OddEven Househld
1 230001 257 156 0-2.7807 per... Eastern 4467 5527 c England 2 2 1
2 230002 158 187 34 2755-161... Morth 3978 B527 B England 2 2 1
3 230004 238 135 2.7807-15.3... Outer ... 3.5640 2.2106 c England 2 2 4
4 230005 207 162 34 2755-161... West 9723 1.1053 B England 1 1 2
5 230006 166 175 0-2.7807 per... East .. 1.0667 1.1083 c England 1 2 2
6 230011 161 189 15.39-34.27_.. Morth .. 9570 1.1083 c England 2 2 2
Click on the Variable View tab (bottom left of screen). In Variable View:
e Each row represents something that varies between respondents (known as a
variable) and each column provides information about the variable including the
name, label and coding information in the Values column
File Edit View Data Transform Analyze Graphs Utilities Add-ons Window Help
E= - B &S . few 3
=Ha e B hEY B a1 9® %
Name Type Width Decimals Label Values Missing Columns Align Measure Role
1 Serial Numeric 6 0 Serial Mumber ... None MNone 10 Right &> Nominal N Input
2 SPoint Numeric 3 0 Sample point :Q% None MNone 7 Right &> Nominal N Input
3 stratiD Numeric 3 0 Stratification [0 None MNone 9 = Right &> Nominal N Input
4 PopBand Numeric 1 0 Population Den... {1, 0-2.7807... Mone 20 Right &> Nominal “ Input
5 GOR2 Numeric 2 0 Government offi... {1, North Ea... Mone 5 &> Nominal “ Input
6 WiFactor Numeric 10 4 Final BSA weig... None None 12 = Right &> Nominal “ Input
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In Variable View, you can see more information about the type of variable, the name (the
short name used to identify the variable), the label (the longer name, often the full question
from the survey questionnaire), whether it is numeric, or string (text variables), or a date, for

example.

In the Values column, you can see the values that have been assigned to the different values
of a variable, for example which values represent which area in the variable “Government
office region 2003 version: Q18" (GOR 2).

The Missing column shows any values which have been allocated as missing in SPSS. Any

cases with missing values will not be included in the analysis.

If you want to view the values or the missing values of a variable from the Variable View,

clicking on the right hand of the values you want to see will bring up the Values window.

Measure shows whether a variable is scale, such as people’'s age, nominal, an unranked
categorical variable (e.g. Country), or ordinal, a ranked categorical variable (e.g. a Likert scale
of agreement)

1 - Agree strongly

2 — Agree

3 — Neither agree nor disagree

4 — Disagree

5 — Disagree Strongly

You can also find out more about the variables by using the Variables window. Use Ultilities >

—r

(sinsiin |

[ #oaiiy
H

Variables..., or click the Variables tool button to open the following dialogue box:
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|‘ufariable

Variable Information:

[+ & Serial Number :...

[+ & Population Den...
[+ &~ Gavernment offi...

[ & Sample point Q...
[ & Stratification 1D ...

[ & Final BSA weigh...

GOR2

Label: Government office region 2003 version :Q18
Type: F2

Missing WValues: none

Measurement Level: Mominal

Value Labels:
[¥ & scaledDUand ... 1 North East
[ & questionnaire ... 5 Morth West
[# & England, Scotla... 3 Yorkshire and Humberside
Il %Version}{f‘r’forﬂ... 4 East Midlands
[ & 1=0dd 2=Even :.. 5 West Midlands
[# & Number living in... 6 sw —
— e P 7 _Factarn

GoTo || Paste |[cancel || Help |

(4] Click on any variable in the left-hand source-list to see more information, including the
1
A4 Value Labels. These are responses to questions. When viewing your data in Data View,
you can click on the Value Labels tool button to toggle between the numerical value of a

variable and the Value Labels:

2.2 Changing settings in SPSS

Before you start analysing data, it is worth understanding some of SPSS's settings. If you are
seeing the Label of the variables in the left-hand column of the Variables window (or other
dialogue box), and would prefer to see the Names, you can change this via Edit > Options
and the following window. Just ensure that Display names is checked, and then click Apply
then OK.
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13 Options |£‘
Pivot Tables ” File Locations ” Scripts ” Multiple Imputations ” Syntax Editor 1
General lL{wer ” Data ” Currency ” Output Labels ” Charts 1
rVariable List: rOutput

© Display labels [ Mg scientific notation for small numbers in tables

@ Display names [] Apply locale’s digit grouping format to numeric values

=~
@ File
© Measurement level Language: ‘Enghsh = |
rRaole:
. § MNatification
To save time, some dialogs allow the use of predefined
field roles to automatically assign variables (fields) to lists ¥ Raise viewer window
in dialogs.

[¥! Scroll to new output

@ Use predefined roles
U I S5 TS rCharacter Encoding for Data and Syntax

rWindow. ()]

Look and feel SPSS Standard b4 Character encoding cannot be changed when any

non-empty datasets are open

[”] Open syntax window at startup

rUser Interface
[] Open only one datasetatatime

Language: ‘English -
ox_J{cancel | _appiy |{ Heip |

2.3 The Statistics Viewer
In both Data View and Variable View, you can use the dropdown menus at the top of the

page (i.e. File, Edit, View, Data, Analyze, Graphs etc.) to manipulate the data and to do
analyses.

When you conduct an analysis, you see the results in the Statistics Viewer window, initially
titled Output 1. In the Statistics Viewer, the pane on the left summarises the analyses

conducted and the pane on the right contains the results.

You can move between the Statistics Viewer window and the data in Data View or Variable

View, by clicking on the tab in the taskbar (the bar that is always at the bottom of the screen).

You can also click on the Go to data button E to return to the data from the Statistics

Viewer.
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3. Exploratory analysis in SPSS 20

The dataset used in the following examples is the British Social Attitudes Survey, 2011. The

British Social Attitudes Survey asks over 3,000 people what it’s like to live in Britain and what
they think about how Britain is run. This dataset can be downloaded from the UK Data Service

website, after completing a short registration.

3.1 Weighting your data in SPSS

Before you begin your analysis, you will need to weight the data to ensure that your sample is

representative of the population. See our What is weighting? guide for further information on

weighting datasets. In the 2011 British Social Attitudes Survey, the “Final BSA weight:Q25" is
WtFactor. To apply this, use Data > Weight Cases, and select Weight cases by, then select

WtFactor and move it into the box on the right by clicking on the arrow, and clicking OK.

@Weight Cases [ = |

- = © Do notweight cases
%::n.alt ® Weight cases by
on Frequency Variable:

& stratlD
& PopBand b d |jq‘."."tFacmr
&5 GOR2
&b Oldwit
&5 ABCVer

&5 Country
L wvwar *|| Current Status: Weight cases by WiFactor

[ OK ][ Paste ][ Reset ][Cancel][ Help ]

3.2 Creating a one-way frequency table and bar chart
From the menu bar at the top of the page, use Analyze > Descriptive Statistics >

Frequencies. From the Frequencies screen, select the variable of interest from the list. In this
example, we are using “Marital status <5 categories> dv :Q145" (MarStat). You can scroll
through the list to find the variable you want, or you can click on any variable in the list and
type the first few letters of the variable you want. This will select the next variable on the list
that starts with those letters. This may be the variable you want, or there may be others with
the same starting letters that come first. Continue to type in the first few letters of the
variable you want until you find the correct variable. Move your variable into the right hand

box by clicking on the arrow. Click OK or Paste.
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Note that if you would like to view the variable Labels rather than the Names, you can right

click on any variable in the dropdown list and select Display Variable Labels.

| a Freguencies ﬂ

Variable(s): —
= _Siaﬁsucs...

&b Serial = &5 Marstat —

&> SPoint

& stratiD Format...

&> PopBand

3, cor

&5 WiFactor

&5 Oldwit

&b ABCVer

2. Canntre -

[ Display frequency tables
[ ok ][ Paste |[ Reset |[cancel|[ Help |

If you click OK, SPSS runs the command as requested. If you click Paste, this opens the
Syntax Editor window. Clicking Paste saves the instructions for the command in a syntax file
(syntax is the name of the computing language that can run commands in SPSS without using
the menu). Saving this syntax allows you to re-run your analysis more easily in future. This is

useful if the data changes, or if you make a mistake in your data manipulation or analysis.

File Edit View Data Transform Analize Graphs Utilties Add-ons Run Tools Window Help

SHE e~ ARLE H PO 9200 B

FREQUENCIES

1k
2 Z FREQUENCIES VARIABLES=MarStat
3 JORDER=ANALYSIS.
4

IBM SPSS Statistics Processorisready| | |In1Col0 | [NUM |

u

Each command in the Syntax Editor window ends with a dot “.". To run the most recent
command, select all of the most recent command and press the large green arrow button. To

run all of the analysis, select all (Control-A) and then press the green arrow.

ukdataservice.ac.uk 8
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>

It is useful to keep the Syntax Editor window open so that you can go back to it after every
command and run that command. You can also save the syntax to use again or make
changes. Experienced SPSS users may find syntax quicker and easier than the menus, as they
have learned the programming language. For example, the above command can be typed in
as:

FREQUENCIES MarStat
You can access help about any syntax command by using the syntax help button within the

Syntax Editor

Running your command/s will open the Statistics Viewer. This will display your frequency

table:
Cumulative
Frequency | Percent | Walid Percent Percent

Valid ~ Married 1676 50.6 50.6 50.6
Living as married 388 1M.7 1.7 62.3
Separated or divorced 321 a7 a7 720
after marrying
Widowed 224 6.8 6.8 78.8
Mot married 7o0 21.2 21.2 100.0
Don't know 1 .0 .0 100.0
Refusal 1 .0 0 100.0
Total 331 100.0 100.0

To view the variable as a graph, return to the Frequencies dialogue box. A shortcut to
opening a previously used dialogue box is by using the Dialogue Recall button on the toolbar

and clicking on the dropdown command:
=~
{ Frequencies

Click on the Charts tool button. You can select a Bar chart or a Pie chart. In this example, a

bar chart shows the frequencies of the variable. Click Continue, then OK or Paste from the

Frequencies dialogue box.
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"@ Frequencies: Charts @

Chart Type

© Mone

@ Bar charis
@ Pie charts
© Histograms:

(]

Chart Values
@

o) Percentages

(continue | cancel || Heip |

Running the command will display the bar chart as output in the Statistics Viewer.

Marital status <5 categories> dv :Q145

1,500

1,000

Frequency

500

T T T T T T T
Married Livingas  Separated or Widowed Not married  Dont know Refusal
married  divorced after
marrying

Marital status <5 categories> dv :Q145

Double-clicking on the chart in the Statistics Viewer opens the Chart Editor, which allows
you to make changes in the way your graph is displayed. There are many possible
amendments that can be made, including labelling changes, changing the colour of the chart

or the order of the bars.

3.3 Dealing with missing values
It may be preferable to perform your analyses to produce valid percentages; a percentage

that excludes certain responses that are not of interest, such as “unknown” responses. You

can do this by setting these responses to missing.
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The frequency table and graph above show two responses “Don’t know”, and “Refusal”. It may
be preferable to exclude these responses from analysis, by setting them to missing. Missing

values are set in the Variable View. Go back to the data, either via the windows at the bottom

of the screen, or via the Go To Data Button Ej . Click the Variable View button:

Yariable View

Use the Variables tool button % to find the variable you want to modify, and note down the
values of the responses you want to set to missing. Using “Marital status <5 categories>

dv :Q145" (MarStat) in this example, the values to set to missing would be 8 = "Don’t know”
and 9 = "Refusal”. Open the dropdown menu in the Missing column of the variable. This
opens the Missing Values window. Click Discrete missing values, and enter the values to set
them to missing:

| t,-'l Missing Values Iﬁ

@ Mo missing values

@ Discrete missing values
g [E |

(& Range plus one optional discrete missing value

[ QK ][Cancel][ Help ]

After setting these values to missing, running the frequency table shows the missing values
separately, and reports a Valid Percent, which is the percentage based on only the valid (non-

missing) data:

Cumulative
Frequency | Percent | Valid Percent Percent
Valid Married 1676 50.6 50.6 50.6
Living as married kL] 1.7 1.7 624
Separated or divorced an 9.7 97 721
after marrying
Widowed 224 6.8 6.8 788
Mot married 700 21.2 21.2 100.0
Taotal 3308 100.0 100.0
Missing  Dontknow 1 i
Refusal 1 .0
Total 2 .0
Total 33N 100.0
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There are some variables in the 2011 British Social Attitudes Survey with missing values
already assigned. For example, the variable “Did you have to retire because of your employer s
policy on retirement age? :Q337" (RRetPlcy), has the values -4 = “Skip, never worked” and -1

= "skip, not retired” set to missing. These will not show up in analysis.

Some datasets may have no information available for a variable for a particular case, in which
case SPSS defaults to system missing “.". It is preferable to assign a value to missing
information so its status is clearly defined, as with the variable RRetPlcy, where the
information is missing for distinct reasons. You can use any value, but minus values stand out

as different and are commonly used.

3.4 Filtering the data to select certain cases
It may be that you wish to analyse subgroups of your data. In order to do this, you can filter

your data to just include the groups of interest. This means that your analysis will use
responses by some and not by others. For example, you may be interested in the responses
by people who are married. Filtering does not delete data from the dataset; it just removes

them from analyses while the filter is on.

From the menu bar at the top of the page, use Data > Select Cases. Select If condition is

satisfied, and click on the [f button:

@ Select Cases @
Select

& Serial § © All cases

% SPoint @ If condition is satisfied
stratiD

&5 PopBand M

&> GOR2 © Random sample of cases

&b WiFactor

&5 Oldwt

&)ABCVer © Based on time or case range

&b Country

&b Xver © Use filter variable:

&5 OddEven -

&5 Housenld |

&b RSex

ﬁRﬂ\ge Output
P25ex

&;F’EReB @ Filter out unselected cases

&;F‘EReI2 @ Copy selected cases to a new dataset

&5 P2Rel

% Eizefq | © Delete unselected cases

SRel S|

Current Status: Do not filter cases

[ ] [Beset J[Cancel][ Help ]
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Then click on “Marital status <5 categories> dv :Q145" (MarStat) and use the arrow to move it
to the box at the top, then type “= 1°, and press Continue, then OK. This selects only the

responses for individuals who are married.

"#R) Select Cases: I =

& Marstats MarStat = 1
& MarStat
&5 Married
% LegStata Function group:

& Legharst All 4]
& ChildHh Arithmetic

&5 NCh415 CDF & Noncentral CDF
&5 NCh318 Conversion

&b HhCho4 Current Date/Time

&5 Hhchs 1 Date Arithmetic

& Hhch1215 @ E B Date Creation |
&5 HhCh1817 Bl fa s s

% RChD4 B B + Functions and Special Variables:
&b RChS11
&5 RCh1215
&5 RCh1617
&b HnType
&5 RelFath
&5 RelMoth
& relproth
&5 relsist
&5 Relson

O Dallaua

N

(D!

[continue | [ cancet |[ Heip |

You can see that the filtering has worked by looking at the data in the Data View. The rows

with lines through the numbers will not be included in the analyses.

File Edit View Data Transform Analyze Graphs Utilities Add-ons Window Help
SHe M e~ Bl H HE BSHE 100 %
| |
|  seial | SPoint | stratb | PopBand | GOR2 | WitFactor | OldWit | ABcver | country |
230001 257 156 0-2.7807 per... Eastern 4467 be27 c England
230002 158 187 34.2755-161... North .. 3978 5827 B England
230004 238 135 2.7807-15.3... Outer .. 3.5640 2.2106 C England
230005 207 162 34 .2755-161... West . 9723 1.1053 B England
] 230006 166 175 0-2.7807 per... East .. 1.0667 1.1053 C England
230011 161 189 15.39-34.27 .. North . 9570 1.1053 C England
230012 176 194 2.7807-15.3... Yorks... 6040 5527 A England
230014 281 118 2.7807-15.3... Wales 5734 5827 B Wales
9 230015 140 179 2.7807-15.3... North . 1.0090 1.1053 C England
230019 320 149 34 2755-161... Eastern 4472 5827 A England

It also says “Filter On” near the bottom right of the SPSS Data View and Variable View

screens.
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You should also run a frequency table of MarStat to see if the filtering has worked correctly.

Don't forget to remove the filter if you wish to analyse the entire dataset, use Data > Select

Cases > All cases.

3.5 Comparing two variables
Cross-tabulations show the relationship between two (or more) categorical variables. For

example, you may be interested in frequency of local bus travel by car drivers. To run this

cross-tabulation, use Analyze > Descriptive Statistics > Crosstabs. Select "How often

nowadays do you usually travel by local bus:Q405” (TRAVEL3) as the row variables, and “May |

just check, do you yourself drive a car at all these days? :Q396" (DRIVE) as the column

variable.

&> Serial a B & TRAVEL3 -
& spain | gatistis. |
& stratiD -Ce.us
& PopBand Column(s): —
% S\SFRi & DRIVE —
L actor
&b Olawt
%AEICVer Layer 1 of 1
Country
&5 WY Ver
&> OddEven

&5 Househld
% ron
f RAge

B o

. @ Crosstabs [é]
sti

=

=

[C] Display clustered bar charts
[] Buppress tables

[ ok J( paste |[ Reset | (cancel || Heip |

Click on the Cells button and select Column Percentages. Click Continue, and OK.

ukdataservice.ac.uk
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May | just check, do you yourself drive a car at all
these days? :0396
Yes Mo Daon't know Total
How often nowadays do Every day or nearly every Count 62 204 0 266
you usuallytravel by local - day % within May | just check, 27% 19.9% 0.0% 8.0%
hus ;G405 doyou yourself drive a car
at all these days? :Q3496
2-5 days aweek Count 128 266 0 394
% within May | just check, 5.6% 25.9% 0.0% 11.9%
do youyourself drive a car
at all these days? :Q396
Once a week Count 127 137 0 264
% within May | just check, 5.6% 13.3% 0.0% 8.0%
doyouyourself drive a car
at all these days? :Q396
Less often but atleast Count 279 13 0 410
once @ month % within May | just check, 12.2% 12.8% 00% | 12.4%
doyouyourself drive a car
at all these days? :Q396
Less often than that Count 416 a6 0 512
% within May | just checl, 18.2% 9.3% 0.0% 15.5%
doyouyourself drive a car
at all these days? :Q396
Mever nowadays Count 1270 183 0 1463
% within May | just checl, 55.7% 18.8% 0.0% 44.2%
doyouyourself drive a car
at all these days? :Q396
Daon't know Count 0 0 1 1
% within May | just checl, 0.0% 0.0% 100.0% 0.0%
doyouyourself drive a car
at all these days? :Q396
Total Count 2282 1027 1 3310
% within May | just checl, 100.0% 100.0% 100.0% 100.0%
do you yourself drive a car
at all these days? :Q396

The first row in this cross-tabulation can be interpreted as 2.7 per cent of people who drive,
travel by local bus every day or nearly every day, in comparison to 19.9 per cent of people
who don't drive. If you were only interested in people who travelled by local bus at any point,

you may wish to set the response “Never nowadays” and “Don’t Know" to missing.

If the crosstab is run to show the Row Percentages rather than the Column Percentages, the

table would be as follows:

ukdataservice.ac.uk 15
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May | just check, do you yourself drive a car at all
these days? Q3496
Yes Mo Don't know Total
How often nowadays do Every day or nearly every Count 62 204 0 266
you usuallytravel by local - day % within How often 23.3% TE7% 0.0% | 100.0%
bus :0405 nowadays do you usually
travel by local bus Q405
2-5 days aweek Count 128 266 0 354
% within How often 32.5% 67.5% 0.0% 100.0%
nowadays do you usually
travel by local bus Q405
Once aweek Count 127 137 0 264
% within How often 48.1% 51.9% 0.0% 100.0%
nowadays do you usually
travel by local bus :Q405
Less often but at least Count 278 131 0 10
once a month % within How often 65.0% 32.0% 0.0% | 100.0%
nowadays do you usually
travel by local bus Q405
Less often than that Count 416 96 0 512
% within How often 81.2% 18.8% 0.0% 100.0%
nowadays do you usually
travel by local bus Q405
Never nowadays Count 1270 193 0 1463
% within How often 86.8% 13.2% 0.0% 100.0%
nowadays do you usually
travel by local bus Q405
Dont know Count 0 0 1 1
% within How often 0.0% 0.0% 100.0% 100.0%
nowadays do you usually
travel by local bus Q405
Total Count 2282 1027 1 3o
% within How often 68.9% 31.0% 0.0% 100.0%
nowadays do you usually
travel by local bus :Q405

The first row of data in this table shows that 23.3 per cent of people who travel by local bus
every day or nearly every day are drivers, and 76.7 per cent are not. This is based on the same
information as the table with column percentages. Whether you choose row or column

percentages will depend on your research question.

3.6 Graphing two categorical variables
A clustered bar chart is often used to visually illustrate the relationship between two

categorical variables. Use Graphs > Chart Builder. This will open a dialogue box giving you
the option to set your measurement level (i.e. nominal, ordinal, scale). If you are confident
that your variables are correctly defined, press OK. At this point, you can also choose to tick

the box Don'’t show this dialog again.
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"2 Chart Builder L= |

0 Before you use this dialog, measurement level should be set properly for each
variable in your chart. In addition, if your chart contains categorical variables,
value labels should be defined for each category.

Press OK to define your chart.

Press Define Variable Properties to set measurement level or define value
labels for chart variables.

[7] Don't show this dialog again

[ 0K ] [Deﬁne Variable Properti es...]

This will open the Chart Builder window:

"8 Chart Builder [ = |

Variables: Chart preview uses example data
& Serial =
&5 SPoint
&5 stratlD
&> PopBand
&5 GOR2
&5 WiFactor
&b Oldwit
&5 ABCVer
&5 Country
&b Xyver
&> OddEven
(e}

[H Category 1
[ Category 2
Gallery [ Basic Elements ” GroupsiPoint 1D ” Titles/Footnotes l
Element
Properties...

- AnisT

Choose from:
Favorites ;
- |
Line Hl—lﬂ
Area
Pie/Palar —— ——
Scatter/Dot ‘ o [i ] ¢’:|J ¢ ¢
Histogram q; ¢ ¢
High-Low
Boxplot
Dual Axes
[ Reset |[cancel ][ Help |

To create a bar chart, ensure that Bar is selected from the Gallery tab in the Chart Builder.
The Chart Builder works on a drag and drop basis. From the Gallery tab, select the chart type
you are interested in (in this instance the clustered bar chart), and drag and drop it onto the

main window. This will open the Element Properties window.

To visually represent the data of local bus travel by car drivers, select “"How often nowadays
do you usually travel by local bus:Q405” (TRAVEL3) from the Variables menu in the Chart

Builder and drag it across to the X-Axis. To cluster this by whether people drive a car or not,

ukdataservice.ac.uk 17



UK Data Service - What is SPSS 20 for windows?

select "May | just check, do you yourself drive a car at all these days? :Q396" (DRIVE) from the
Variables menu, and drag this across to Cluster on X: set color. Within the Element

Properties window, under Statistic, select Percentage(), and click Set Parameters...

. "u-'l Element Properties lﬂ

Edit Properties of:
Bar1 - @
K-Axis1 (Bar1)
Y-Axis1 (Bar1)
Gronnnlar (Bary s

Statistics

Variable:
Statistic:

| Percentage () bt

["] Display error bars
Error Bars Represent

Bar Style:
| 0 Bar =

oy ) Gonet

This will open the Element Properties: Set Parameters window. For this data, it makes sense
to set the Y-Axis as showing the percentage of people in each response to the bus travel

question. To do that, select Total for Each Legend Variable Category (same fill color) from the
dropdown menu and click Continue. You can also use the Element Properties window to set

Axis labels. Click Apply in the Element Properties window and then on OK to run the graph.

13 Element Properties: Set Parameters lﬂ

Denominator for Computing Percentage:

|§Total for Each Legend Variable Category (same fill color) = |

[Cmﬁnue][ Cancel ][ Help ]
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Drive
60.0% acar

W es

Ero
50.0%

40.0%

30.0%

Percent

20.0%

10.0%

0.0%—

Every day 2-5daysa Oncea Lessoften Lessoften Mewver
or nearly week week but at least  thanthat nowadays
every day once a

manth

How often do you travel by bus

Depending on what you want your data to show, you could choose to transpose these two
variables in the Chart Builder. You could show separate bars for frequency of bus travel,

clustered by car driving, which would make your graph look very different:

How often do you travel
by bus

100.0%-] Every day or nearly every
day

2-5 days a week

Once a week

Less often but &t least once
amonth

80.0% Less often than that
Never nowadays

60.0%

Percent

40.0%

20.0%

00%=

Drive a car

Chart Builder can be used for a variety of graphs. The table below shows a summary of some
basic analyses and graphs that can be used to summarise a single variable and then the

relationship between two variables of different measurement levels.

With a categorical: | With a

Level of nominal or ordinal scalar/continuous
measurement To summarize variable variable
variable

Categorical: nominal | One-way frequency | Cross-tab (two-way | Mean (average)

ukdataservice.ac.uk 19



UK Data Service - What is SPSS 20 for windows?

or ordinal

table

Pie chart

Bar chart

Median for ordinal
variables

Mode for nominal

variables

frequency table)

Clustered bar chart

Histogram

Scalar/continuous

Mean (average)

Histogram

Mean (average)

Histogram

Scatterplot
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4. Data manipulation in SPSS

The dataset used in the following examples is the British Social Attitudes Survey, 2011. The

British Social Attitudes Survey asks over 3,000 people what it’s like to live in Britain and what
they think about how Britain is run. This dataset can be downloaded from the UK Data Service

website, after completing a short registration.

It is often necessary to derive a new variable for analysis by grouping certain categories of
existing variables together (recoding variables), or combining information from more than

one existing variable (computing new variables).

4.1 Recoding variables
If you were interested in whether people thought the standard of care in the NHS had

improved or declined in the last five years, you may wish to combine some of the categories
of the variable "how much better or worse the general standard of health care on the NHS

over the last five years? :Q363" (NHS5yrs).

Select Transform > Recode into Different Variables... You have the option to recode into the
same variable. However, this means that you cannot check your recoding against the original
variable. It is advisable to recode into different variables so that you can check your work and
recode again if required. This opens a new window. Select NHS5yrs from the variable list, and
move it across into the Numeric Variable box using the arrow. Type in the name of your new
variable in the Output Variable Name box, then enter the description in the Label box

underneath. Click Change.

"@ Reccde into Different Variables @
Mumeric Variable -= Qutput Variable: Output Variable
RRetCare =] MHS5yrs —= NHSstandard

Name:
&5 RRetPrin —
& RRePack L [NHSstangara |
&> RRetlJob Label:
&5 RRetwant |Standard of NHS improve |
&b RRetOth
&5 NHSSat
&5 GPsat
&5 Dentsat
&b Inpat3at
&5 OutpaSat
& AESat 0ld and New Values...
&b NHS10Pay
&) NHSLimi2 = (optional case selection condition)

[Beset ][Cancel][ Help ]
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Click Old and New Values to specify the values of new variable. In the new window that
opens, click on Range: and enter the values to be combined, and the new value in the Value

box under New Value. The original values for this variable were as follows:

Original coding Coding for new variable
-2 = "not asked this

version”

1 = "Much better” }

2 - “Better” — 1 = "better”

3 = "About the same” o 2 = “the same”
4 = "Worse” }

. . 3 ="worse”
5 = “Much worse

8 = "Don’t know”
9 = "Refusal”

As this is recoding into a different variable, there is no need to worry about the values that
aren't carried across, as they will automatically be set to system missing. For the purposes of
this example, we want a variable with three outcomes — “Better”, “The same”, “Worse", and so

will combine the values as follows.

"\.",-\ Recode into Different Wariables: Old and New Values @
Old Value Mew Value
© Value: @ Value: | |
© System-missing

© System-missing @ Copy oldvalue(s)
© System- or user-missing
® Range: Old —= New:

| | 3—=2

1thru 2 —=1
through 4thru g —=23

@ Range, LOWEST through value:

(@] Range, value through HIGHEST:

[] Outputvariables are strings
© All gthervalues

@

[continue || cancel || Heip |

Make sure that you have added the last change by clicking on Add, and clicking Continue and
then OK.
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To add values (i.e. "Better”, “The same”, “Worse"), go to the Variable View and find the new
variable. Newly created variables will be added at the end of the dataset. In the Values

column, click to the right to open the Value Labels window, and define the values as follows,

and click OK:
t,-'l Value Labels ﬁ
Value Labels
vae [ | Speling..
Label: | |
1 ="Better”
2 ="About the same”
3="Waorse”

[ QK ][Cancel][ Help ]

At this stage, it is a good idea to run a crosstabulation of your variable and the original to
check that the recode has worked. Select Analyze > Descriptive Analysis > Crosstabs... This

will show whether the recode has done what you expected it to.

Standard of NHS improve decline stay the same
Aboutthe
Better same Worse Total

how much better orworse  Much better &0 i 0 60
the general standard of Better 289 0 0 289
health care on the NHS
over the last five years? - Aboutthe same 0 422 0 422
Q363 Worse 0 0 251 251

Much worse a0 a 55 55
Total 349 422 306 1077

The syntax for this process is as follows:

RECODE

NHS5yrs (3=2) (1 thru 2=1) (4 thru 5=3)

INTO NHSstandard.
VARIABLE LABELS NHSstandard 'Standard of NHS improve decline stay same’.
EXECUTE.
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ADD VALUE LABELS NHSstandard
1 "Better”
2 “About the same”

3 "Worse”

4.2 Computing new variables
Computing new variables allows for combining data from different variables. For example,

you may be interested in the opinions of individuals aged 50 and over who are unemployed ,
using the 2011 British Social Attitudes Survey. Computing this variable means combining
information from the variables “Person 1 age last birthday :Q50" (Rage), and “Respondent

economic activity in last week< Priority coded> :Q693" (REconAct):

Respondent economic activity in last week< Priority coded> :Q693

Cumulative
Frequency | Percent | Valid Percent Percent

Yalid In full-time education (not Ga 21 21 21

paid far by employer,

including on vacation)

On government 10 3 ] 2.4

training/employment

programme

In paid wark {or away 1718 518 5148 542

temporarily) for at least 10

hours inweek

Waiting to take up paid 9 3 3 545

work already accepted

Unemployed and 107 3.2 32 a7y

registered at a JobCentre
or JobCentre Plus

Unemployed, *not* 36 11 11 58.8
registerad, but actively
looking for a joh (of at
least 10 hrs a week)

Unemployed, wanting a 27 8 8 59.6
job (of atleast 10 hrs per
weelk) but *not* actively
looking for a job

FPermanently sick or 174 53 53 64.9
dizabled

Wholly retired from work 404 273 273 922
Looking after the home 233 7.0 7.0 99.3
(Doing something else) 24 i T 100.0
WRITE IM)

Total 3311 100.0 100.0
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Select Transform > Compute Variable... This opens the Compute Variable window. Name
the target variable unemp_50 and then build up the expression to select people aged 50 and

over, and unemployed. Click Ok.

. "\",J Compute Variable

Target Variable: Mumeric Expression:
_  |RAge =49 & (REconAct="5 | REconAct = 6 | REconAct=T7)

Type & Label...

&5 Serial = RS
&b SPoint ;

& stratiD Function group:

4o DEEEEE | ~
&) GOR2 Arithmetic

&5 WitFactor CDF & Noncentral COF

&) Oldwit Conversion

&b ABCVer Current Date/Time
Date Arithmetic

&5 Country
S o oo e
&) OddEven : : :

. Functions and Special Variables:
e ) )| o

& RSex
f RAge
&b P25ex
&5 P2Rel3
&5 P2Rel2

&5 P2Rel

&5 Pagex =]

(optional case selection condition)

[ OK ][Easte][&eset][Cance.l][ Help ]

In the numeric expression, “Rage > 49" denotes that we only want to select individuals aged
over the age of 49. The rest of the expression is in brackets as we want to combine the
information on unemployment from several values. (REconAct = 5 | REconAct = 6 | REconAct
= 7) denotes that we want to select the individuals who have the code of “5" OR “6" OR 7"

from the variable REconAct.

This process produces a variable which takes the value 1 when the logical expression is true,
and 0 otherwise. It is a good idea to check whether the variable has computed correctly by

running a crosstab of all three variables (the two originals and your computed variable). You
can run a three-way crosstab by selecting a third variable as a layer variable using Analyze >

Descriptive Statistics > Crosstabs..., or by adding a second “by” statement in the syntax.
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Don't forget to define variable labels and value labels for the new variable “unemp_50" in the

Variable Viewer once you have run this command.

The syntax for computing this variable is as follows. The first line sets a default value of -1 to
explicitly handle information which is Not applicable (e.g. if you have any missing data
through non-response). Where the logical condition is satisfied as true, this syntax asks SPSS
to code the variable as 1 (and O where false). The variable label and value labels are also
defined.

COMPUTE unemp_50 = -1.

if (RAge > 49 & (REconAct = 5| REconAct = 6 | REconAct = 7)) unemp_50 = 1.
If (Rage < 50 or (REconAct < 5 | REconAct >7)) unemp_50=0.

VARIABLE LABELS unemp_50 Unemployed over 50 .

EXECUTE.

ADD VALUE LABELS unemp_50
-1 Not applicable
0 No

Yes
This code can be reused by editing the variable names and logical expressions. Remember

that SPSS can automatically generate syntax for you; until you become more experienced, all

you have to do is edit it for future use.
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5. Using hierarchical data in SPSS

The dataset used in the following examples is the English Housing Survey 2011-2012:

Household Data (EHS). This survey asked over 13,000 households about their housing and

local environment. This dataset can be downloaded from the UK Data Service website, after

completing a short registration.

Hierarchical datasets consist of data at more than one level of measurement where lower
level data are nested in one or more higher levels. For example, in a survey in which
individuals within households are interviewed, both individual and household variables may

available. To link individuals to household, there will be a household identifier.

Hierarchical data are stored either as a single file containing variables at multiple levels (e.g.
an individual level file containing individual and household variables) or in a multiple file
format with one (or more) file at each level of measurement (e.g. an individual level file and a
separate household level file). The information contained in the two formats is identical and

Sections 5.1 and 5.3 of this chapter in effect show how to move between the two formats.

The examples in this guide use two level hierarchical data from the EHS as an example but the

methods shown also apply to more complex hierarchical data.

5.1 Selecting one individual per household

Suppose you have individual and household variables contained in a single dataset. Analyses
conducted using this data file are at the individual level by default. If you want to conduct
household level analyses, you can select on individual in each household to create a

household level dataset.

Use the file people.sav from the interview folder in the EHS. This is an individual level file
that contains individual and household variables (e.g. sex at the individual level and dvhhsize,

household size, at the household level) and contains a household identifier aacode.
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If you want to use these data to do household level analyses, you can select one person in

each household® by selecting only the Household Representative Person (HRP).

Household Representative Person (HRP)

The Household Reference Person (HRP) is a term commonly used in survey data to
indicate a member of the household who is equivalent to a head of household. Where
there are joint householders, the HRP is defined by the Office for National Statistics (who
produce many of the UK large-scale surveys) as the individual with the highest income. If
the joint householders have the same income, the eldest is selected. The HRP can be
used in analysis to ‘represent’ the household in terms of income, say, or to select a single

member of each household.

The way in which the HRP's identity is stored varies from dataset to dataset. For example

you may have a:

- binary variable that indicates whether the respondent is the HRP or not

test whether the respondent’s own person number is the same as that of the HRP
- variable that indicates the respondent’s relationship to the HRP

See the documentation that comes with your dataset to find a variable that identifies the

HRP or some other variable that will allow you to select one individual per household.

- a variable which indicates the person number of the HRP, you will then need to

Open the file people.sav. To select the HRP only via the menus, use Data> Select Cases...

! Note that the EHS contains household level datasets that are more appropriate for

household analysis.
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Q peoplesav [DataSet?] - IBM 5P5S Statistics Data Editor
File Edit View Data Transform Analyze DirectMarketing Graphs Ulilities Add-ons Window Help

% E E [ Define Variable Properties. . e 52; _
= == = 2,] Set Measurement Level for Unknown... E= = L
L | |m CopyDataProperties...
| g® New Custom Attribute. . | dwsize | sex | ageif | age |
1 JO01 Define Dat 7 1 2 -9 45
2 Joptq{ B Defne Dates.. 7 1 2 9 77
3 10011 Define Multiple Response Sets.. 7 1 2 g 58
4 Joo11 Validation P 1 2 9 84
5 Joo11 B Identify Duplicate Cases... 7 1 2 9 52
6 J0011 F Identify Unusual Cases... 7 2 2 -9 48
JUU” {5 Sort Cases... 7 2 1 9 15
8 00N e 1 Variaples.. 7 2 2 9 56
9 JO011 T T 2 1 -9 32
ranspose...
10 JO011 L ) 2 2 1 -9 67
1 |Joorq  MeraeFiles "2 2 2 9 69
12 |Jootq P Restucture.. 1 5 2 9 39
13 |Joo1q FE:Acgregate.. 1 5 1 9 a7
14 JO01 Orthogonal Design L] 5 1 -9 7
15 J0011 2 Copy Dataset 1 5 1 -9 5
16 JO011 = spiit File... 1 5 2 -9 1
17 JO011 @gelect[)ases... 1 4 1 -9 50
18 JO011 1 4 2 -9 50
s Weight Cases...
19 J0011 — 1 4 2 -9 16

Then select the option If condition is satisfied and click on the If... button.

@ Select Cases . . u
rSelect
@) persno = | © Al cases
& hrp @ If condition is satisfied
&5 hrppart :
& dvhsize
&b sex Random sample of cases
& ageif Sample...
& age .
& hallres Based on time or case range
&b xmarsta Range...
% marchk Use filter variable:
livwith
&5 hrpid we B
&5 hnidr
&5 hihnum ~Output
&5 intelda
& inteldn @ Filter out unselected cases
&, ro Copy selected cases to a new dataset
& oz Dataset name:
ﬁ rgi = Delete unselected cases
i —

Current Status: Do notfilter cases

—

OK Pas
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The variable HRP is coded so that HRP=1 if the individual is the HRP and 2 if the individual is
not the HRP. In the Select Cases: If dialogue box, either type in hrp=1 or select hrp from the
list of variables in the left-hand box, use the arrow to move it to the box at the top and the

calculator buttons to add ‘=1". Press Continue.

. "l.-',-‘ Select Cases: If - ] |

&4 aacode = hrp=1
&5 persno +
&> hrp
& hrppart Function group:

&b dvhsize Al i
& sex Arithmetic

CDF & Moncentral CDF
Conversion

f ageif
& age

Current Date/Time
Date Arithmetic

&b hallres
&5 xmarsta
Date Creation |

&5 marchk
& lvwth
&b hrpid
&5 hhidr
&5 hihnum
& intelda
&b Inteldn
&b 101

&b 102

&5 103

&b 14

&5 108

D en

4
3333

Functions and Special Variables:

0135
LELEE
RO

I
o
)
L]
-

K

[Continue][ Cancel ][ Help ]

It is advisable to check that this has worked as intended by doing a frequency of the variable
hrp. Analyses in SPSS will be conducted only on this selection of the data until all the data are
selected again or some other selection is made. To select all the data, use Data> Select

Cases... and choose ‘All cases’.
Syntax to filter cases

Using syntax, you can either use the filter command to temporarily select cases (until the

filter is removed or changed):

COMPUTE filter_S=(hrp=1).

VARIABLE LABELS filter_$ ‘hrp=1 (FILTER)'.

VALUE LABELS filter_S 0 'Not Selected' 1 'Selected'.
FORMATS filter_S (f1.0).

FILTER BY filter_S.
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EXECUTE.
Syntax to temporarily drop cases

Alternatively, you can use the select command but note that unless preceded by the
temporary command, the select command permanently drops all unselected cases. The
temporary command applies until the next executable command — e.g. most processes
which produce output. The syntax to temporarily select the HRP and conduct some simple

analyses is below:

TEMPORARY.

***note that the temporary command means that the following selection is only in place until

the next executable command.
SELECT IF (HRP=1).

DESC SEX persno.

***desc is an executable command.
TEMPORARY.

SELECT IF (HRP = 1).

FREQ SEX persno.

Syntax to permanently drop cases
Instead of using a temporary filter, it is possible to drop cases selecting only one person per
household then save the file. In SPSS this can be achieved using the select command

without the temporary command.

SELECT IF HRP = 1.
SAVE OUTFILE="newfilename’
/COMPRESSED.

5.2 Summarising characteristics of groups in hierarchical data

Suppose you have individual and household variables in a single individual level file and you
wish to create a new summary household-level variable (e.g. the age of the oldest personin

the household) using individual level data. The example below shows a simple example of
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computing the age of the oldest person. It assumes that you have a household ID and age

variable.
Individual data Summary variable age_maxin
household
Person 1 Household 1: age = 47 age_max = 47
Person 2 Household 1: age = 43
Person 3 Household 1: age = 18
Person 1 Household 2: age = 74 age_max =74

Using the individual level dataset people.sav, from the drop-down menus, select Data>

Aggregate.

'@Aggregate Data ] &

Break Variable(s):

&5 persno = &4 aacode
@b hrp +
&5 hrppart
&5 dvhsize ~Aggregated Variables

&b sex

6& ageif Summaries of Variable(s):
y age age_max = MAX(age)
&5 hallres

&5 xmarsta

&b marchk
&b livwth
&5 hrpid
& hhidr r |
&5 hihnum

& intelda [ Number ofcases  MName: [ EREAF

D imtaldR

| Name & Label... |

Kl

rSave

@ Add aggregated variables to active dataset
Create a new dataset containing only the aggregated variables

rOptions for Very Large Datasets

[ File is already sorted on break variable(s)
[7] Sort file before aggregating

[ ok || paste || Reset || cancer|[ Help |
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Put the household ID aacode in the Break Variable(s) box and choose the variable age and
move it into the aggregated variables box. Click the function button to choose the
appropriate function to put in the Summaries of Variable(s) box. In this case, choose
‘maximum’. The new variable is named ‘age_max’ by default. In the Summaries of Variable(s)

box, you should see age_max=MAX(age).
You have a choice as to how to store your resulting variable:

By default SPSS selects Add aggregated variable to active dataset which will match the new
variable back on to the open file so that every person in the original file will contain the new

household summary variable.

Alternatively to can produce a hew household level file which will have one case per
household and contain only the new variable(s) and the household ID variable, choose either
Create a new dataset containing on the aggregated variable or Write a new dataset
containing on the aggregated variable. The latter writes a new file to memory but does not

open itin the current session.

The commands below create a household level file with the oldest person in the household

where the new variable is added into the existing individual dataset.

Here is the syntax for this:
kkkkkkkkkhkkkhkkkhkkkhkhkhkkhkhkhkkhkhkhkkhkhhkkhkhkkkhkhkhkkhhkkhhkhkkhhkkhkhhkkhhkkhkkhkkhkkhhkkhkkhkkhkkkkkkkk

* SPSS syntax to generate household file with oldest personin .

* household.

kkhkkkkkkkhkkkkhkhhkhkhkhhkhkhhkkhkhkhhkkhkhhkhkhhkhhkhhkhhkhkhhkhhkhkhkhkkhhkkhkkkkkkkkk

*now create a file with one case per value of the household ID aacode.

AGGREGATE
/OUTFILE=* MODE=ADDVARIABLES
/BREAK=aacode
/age_max=MAX(age).

kkkkkkkkkkkkkkkkhkhkhhhhkhkkkkkkkkkhkkkkhhhhhkhkhkkkkkkkkkkkkkkkkhhkkkkkkkkkk

Or, to save the new variable in a household level data, use:
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kkhkkkkkkhkkhkkhkkhkkhhkkhkhhkkhkhkhkhhkkkhkhhkhkhhkhhkhkkhkhkhhkhkhhkhhkhhkhhkhkhkhhkhkkhhkhkkhhkhkkkkkkk

* SPSS syntax to generate household file with oldest personin .
* This opens the new household dataset but does not save it —
* dataname is the name of the dataset that is given to the household

* dataset when it opens.

kkkkkkkkkkkhkhkkkkkhkhkhkhkkhkhkkkkkhkhkkhkhkhkkhkhkhhhkhhkhkkhkkhkkhkkkhkkkkkhkkkhkkhkkhkkkkhkkkk

DATASET DECLARE dataname.

AGGREGATE
/OUTFILE="'dataname’
/BREAK=aacode
/age_max=MAX(age).

kkkkkkkkkkkkhkhkhkkhkhkhkkhkkhkkkhkkhkhkhkhkhkhkhkhkhkhkhhkhhkkhkhkhhhhkkhkhkkkhkhkkkkkkkkk

kkkkkkkkkkkkhkhkhkkhkhkhkkhkkhkkkhkkhkhkhkhkhkhkhkhkhkhkhhkhhkkhkhkhhhhkkhkhkkkhkhkkkkkkkkk

* SPSS syntax to generate household file with oldest person in .
* This opens the new household dataset and saves it, where <newfile.sav> is

* the name of the file with extension.

kkkkkkkkhhkkkhkkhkhkkhkhkhkhkhkhhkhhkkhkhkhhkhkhkkhhkhkhhkhhkhkkhkkhkhhhkhkkhkhkhkhhhkhkkhkkkkkkhkkkk

AGGREGATE
/OUTFILE="<newfile.sav>'
/BREAK=aacode
/age_max=MAX(age).

kkhkkkkkkkhkkkkhkhhkhkhkhhkhkhhkkhkhkhhkkhkhhkhkhhkhhkhhkhhkhkhhkhhkhkhkhkkhhkkhkkkkkkkkk

5.3 Attaching household data to an individual level file

Suppose you have hierarchical data held in two files, one with individual level variables and

one with household level variables and in which each contains the household ID aacode.

To attach the household and individual level datasets to create an individual level dataset, first
sort all files to be combined by the household ID variable aacode, save and close them. To
sort the data by aacode, use Data> Sort Cases..., then select aacode and move it into the Sort

by: box.
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Using a household level file from the EHS generalfsil.sav (in the derived folder when the
data are downloaded), from the menu, choose Data> Merge Files> Add Variables, and select
the dataset: people.sav (in the interview folder when the data are downloaded) to add. In the
new window, tick Match cases on key variables in sorted files and choose Active data set is
keyed table. Then click on the ID variable aacode in the left-hand window and click on the

arrow to move it to the Key Variable box as shown below:

'!?5;=: Add Variables from \\nask-man.ac.ukihome$\Desktop\people.sav [ﬂ |
Excluded Variables: New Active Dataset:
rumorphi®) a
aaagfh11(*)
paired(*)
casecat(®)
+ | | |fqtr)
fmonth(*)
fyear(*)
tenure8x(*)
tenuredx*) [l
[¥] Match cases on key variables in sorted files Key Variables:
© Both files provide cases aacode=
@ Mon-active dataset is keyed table i
@}fﬁdiue datasetis keyed table?
(]
(*)=Active dataset
(+)=Vnask.man.ac.ukihome$\Deskiop\people.sav
| oKk ]| paste || Reset || cancel || Help |

Press OK. Look at the new data in Data View. The variable aacode now contains multiple
rows with the same value representing different people in the same household. Finally save

the data under a new name.
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File Edit View Data Transform Analyze DirectMarketing Graphs Utilities Add-ons

SHEe I - B M 5 B
|1

15 fqtr
| aacode || rumaorph || aagth11 || paired || casecat ||
1 J0011101 1 1152 38 1 1.00
2 J0011102 1 796.28 1 1.00
~ 3 |Joot1103 1 902 35 0 4.00
4 J0011104 1 1637.99 0 5.00
5 J0011106 1 1500.43 0 4.00
6 J0011202 1 1155.30 1 1.00
7 J0011202 1 1155.30 1 1.00
8 J0011203 1 1894.57 0 4.00
9 J0011203 1 1894.57 0 4.00
10 Jo011204 1 1206.46 0 4.00
11 Jo011204 1 1206.46 0 4.00
12 [Joot1207 3 1232.20 0 5.00
13 Jo011207 3 1232.20 0 5.00
- 14 |Joot1207 3 123220 0 5.00
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Check that the merge has worked as intended

If you merged all the household variables into the individual level dataset, the same
information should be in the new file as there was in your two original files. Look at the

data:

— does it look right? |Is the merged dataset at the correct level of measurement? Are
there lots of missing data that weren't in the original datasets? If so, should there

be?

— do frequency tables of the same variables in both the old and merged individual

level files. The results should be the same.

— select only the hrp in the merged file and do frequency tables of some of the
household level variables. Then do the same using the original household file. The

results should be the same.

Using syntax to match files

When matching, it is important that the files are sorted by the variables that they are to be

matched upon. You can achieve this by using the sort command.

The match command is a flexible command which can be used to match cases, either by
matching case by case, or on the basis of an identifier. Where you have files at different
levels, the upper level file is treated as a ‘lookup table’ from which values, uniquely defined by
the ID, can be looked up and distributed to all cases in the main (lower level) file which have
the ID variable value. Accordingly, if you seek to distribute household level data to the

individual level, the household file will be the “table” and the individual file will be the “file”".

Note that you can replace a filename for either the lookup table or file with * when that file is
already open. In this example, the household level file is already open, so it has been replaced

with a "*'.

The execute command is optional; however you should use this (or another executable
command such as frequencies) in order to execute the command as the command will not

execute on its own.
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The syntax for this is as follows, where <householdfilesav> is the household level file with

path and <individualfile.sav> is the individual level file with path:

GET

FILE="<householdfile.sav>".

SORT CASES BY aacode (A).

MATCH FILES /TABLE=*
/FILE='<individualfile.sav>'
/BY aacode.

EXECUTE.

SAVE OUTFILE='newname.sav’
/COMPRESSED.
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6. Linking and merging files in SPSS

The dataset used in the following examples is the English Housing Survey 2011-2012:

Household Data (EHS). This survey asked over 13,000 households about their housing and
local environment. This dataset can be downloaded from the UK Data Service website, after

completing a short registration.

Many datasets come as a single file but others are supplied in multiple files. These files may
contain:

1. Information about the same cases at the same level of measurement (e.g. two files
containing information about the same households but with different variables in
each)

2. Hierarchical data: data that contain more than one level of measurement nested
within another (e.g. individuals within households in individual level file(s) and
household file(s)).

3. Data with the same variables but different cases (e.g. the same survey conducted in

England and Wales with the data for each country in its own file)

Combining together (merging) multiple files that contain the same cases involves using one
or more matching variables that uniquely identify each case (e.g.an individual ID variable

and/or household ID etc.) to link the data from the same case in different files.

6.2 Linking multiple files at the same level of measurement

In the EHS, the generalfsil.sav file contains the weight and interviewfs11.sav contains the
answers to the household interview. Both files are at the household level and contain all the
cases. To analyse the interview data using the household weight, these two files must be

merged.

To do this, first order the matching variable (aacode) in the same way in both data sets If in by
right-clicking on the title of the aacode column and select Sort Ascending. Save and close
both files.
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File  Edit “iew Data  Transform  Analyze  Graphs  Wilties  Add-ons YWind

SHE @ b0 LER A Al S0 B

: aacade GO011101
aacode —d | fatr | fmantl

=N AN ] Cut ATET T
4596 0421109 Copy aired 1
4597 0421110 Paste aired 1
4593 GO421111 Clear aired 1
4599 0421112 ﬁ Insert Varisble aired 1
4600 G0421113 aired 1
4601 | G0421201 =ort Ascending aired 1
4602 |GD421202 =ort Descending aired 1

Open either one of the files. You can open and use either file first in this instance because
there is a 1:1 match of households between the two files so it makes no difference whether

you add the interviewfsll.sav to the generalfsll.sav or the other way round.

Open generalfsil.sav. To add a file to the open file, use the menu: Data> Merge Files> Add

Variables to get to the following screen:

cai Add Variables to interviewfsQB.sav[DataSet1]

Select a dataset from the list of open datasets or from a file to merge with the active
datazet

| ) An open dataset

(3) [0 external SPES dats file

| | Erowse...

Mon-SPES data files must be opened in SPES before they can be used as part of & merge.

Cortinue H Cancel ” Helg ]

Browse to find the second data set: interviewfs11.sav then press Continue.

In the new window, select Match cases on key variables in sorted files, and Non active dataset
is a keyed table. Then click on aacode in the left-hand window and click on the arrow to

move it to the Key Variable box as shown below:
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dd Yariables from T:\contents-visible-to-teaching-userma

x|
Excluded Variables: Mewe Active Dataset:
tenuredx®) |4
tenurezx ) E
garEHCS*)

il region3x*)
‘ + ‘ rumargh*)
| |rriam
nrfEE*)
nrfa(*)
ek 040*)

dl

7 . . '
Match cases on key variables in sorted files Key Varisbies:

() Bath files provide cases

FAcoe
\a) N:un-actwe datazet iz keved takle
() Active dataset is keyed table
*=Active datazet
[+1=T wonterts-vishle-toteaching-uzernames HLE Warkshopinterviewfz08 sav
| Ok _“ Paste || Reset || Cancel || Help

Press OK to merge the files. The new merged data set is now displayed: you should see that
there were 19 variables in total before the merge, and now there are 126 variables. The new

data set should be saved under a new name.

Merging files when one file contains information about some of the cases only

You can use the same method to merge two files with the same level of measurement but for
which one file contains a subset of the cases contained in the other. Because thisis not a 1:1
correspondence between the cases as in the example above the choice of data to open first

does affect the resulting merged dataset.

If you open the file with all the cases first and add the subset file to it, you will obtain a file
with all the cases in it. The dataset will contain values where they exist and missing values

(system missing blanks) for the cases not contained in the subset.

If you open the subset file first and add the other file to it, you will obtain a file with all the

variables in both datasets but only for the subset of cases.
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The syntax to sort and merge two household files is below, where <householdfilel.sav> is the
file name with file path for the first file and <householdfile2.sav> is the file name with file path

for the second file and <mergel.sav> is the saved name and path of the new dataset.

kkkkkkkkkkkkkkkkhkkkkhkhkkhhkkhkhkkhkkhkkhkkhkhkhkhkkhkhkhkkhkhhkhkhkkhkhkhkhkhkhkhkhkkhkkhkkhkhkhkhkhkkhkkkhkkkkkkkk

* Opens, sorts and saves the two household files and closes <householdfile2.sav>.
Tk koo kb ko koo kb ko ok bbb kbbb ok ko ok ko ok koo ok ko ok ko ok
GET
FILE="<householdfilel.sav>'.
DATASET NAME DataSetl WINDOW=FRONT.
SORT CASES BY aacode (A).
DATASET ACTIVATE DataSetl.
SAVE OUTFILE="<householdfilel.sav>’
/COMPRESSED.
GET
FILE="<householdfile2.sav>".
DATASET NAME DataSet2 WINDOW=FRONT.
SORT CASES BY aacode (A).
DATASET ACTIVATE DataSet2.
SAVE OUTFILE="<householdfile2.sav>'
/COMPRESSED.
DATASET ACTIVATE DataSetl.
DATASET CLOSE DataSet2.

kkkkkkkhkhkkkkkhkkhkhhkkkhkhkkhhkhkhhhkhkhkkhhkhkhhkhhkhkhkhkhkhkhhkhkkhkhkhkhkhkhkhhkhkhkhkhkhkkhkkhkkhkkkhkhkkkkkkkkk

* Merges the two household files and saves the new merged file as merge.sav .
N ———
MATCH FILES /FILE=*

/TABLE="<householdfile2.sav>".

/BY aacode.
EXECUTE.
SAVE OUTFILE='<mergel.sav>'
/COMPRESSED.
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6.3 Attaching household level data to individuals

Datasets sometimes come with multiple files because the files contain data at different levels

(e.g. individual, and household).

When the data are of the following format, you may add the higher level data to the lower

level file (e.g. add household variables to an individual level dataset):
e Ahigher level file (e.g. household level)

o Alower level file (e.g. individual level) where the lower level data are nested within the

higher level data (e.g. individuals within households)

e Both files contain a matching variable to allow the higher level to be identified in each

file e.g. both contain a household ID variable.

The data described are an example of hierarchical data. See Section 5.3 in Chapter 5 about

using hierarchical data in SPSS for how to attach higher level data to lower level data in a

hierarchical dataset.

6.4 Merging files with different cases but the same variables

If the two datasets have the same variables but different cases you may want to combine the
files. For example, when using a survey conducted in both England and Wales with the same
questions with the data contained in 2 files, you may want to create a dataset for England and

Wales together.

In this instance, there is no matching variable because there is no linking of cases. They are

different cases in each file.
To achieve this in SPSS, use Data> Merge files > Add Cases

One thing to remember when doing this is that you may not have a unique person identifier
any more once you add files together so you might want to consider making a new person

identifier.
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